PaGoDump and PaGoRestore v9.5.1 are available

PostgreSQL v9.5.1 support introduced. Support for 9.4.5 and 9.3.7 versions added as well. Some bugs fixed.

You're welcome to download the latest release from our website at:

Full changelog:
[!] v9.5.1 dump & restore libraries (pg_dump.dll, pg_restore.dll) added
[!] v9.4.5 dump & restore libraries (pg_dump-9.4.5.dll, pg_restore-9.4.5.dll) added
[!] v9.3.7 dump & restore libraries (pg_dump-9.3.7.dll, pg_restore-9.3.7.dll) added
[+] "Enable Row Security" extended option added
[+] "Use IF EXISTS clause" extended option added
[*] Avoid dump/reload problems when using both plpython2 and plpython3
[*] Make PaGoDump mark a view's triggers to be processed after its rule, to prevent possible failure during parallel restore
[*] PaGoRestore handles inherited NOT VALID check constraints correctly
[*] PaGoRestore handles object privileges sanely when dumping from a server too old to have a particular privilege type
[*] PaGoRestore supports cases where the postgres or template1 database is in a non-default tablespace
[*] Support for shell types (not fully defined) to PaGoRestore added
[*] Temporary files created during a PaGoRestore run with tar-format output are not world-readable now
[-] "Improper quoting of domain constraint names in PaGoDump" bug fixed
[-] Assorted corner-case bugs in PaGoRestore's processing of extension member objects fixed
[-] Assorted minor memory leaks in PaGoRestore fixed
[-] Selection of default zlib compression level in PaGoRestore's directory output format Fixed

Please don't hesitate to ask any questions or report bugs with our Support Ticketing system available at

Back to the news section ›
Site map | Search | Privacy Policy | Terms of Use | Contact Us
Copyright © 2000—2018 Microolap Technologies LTD. All Rights Reserved.
All trademarks are the sole property of their respective owners.